注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

电脑点菜博客

电脑点菜请用金奇点菜网

 
 
 

日志

 
 

易语言用户注册语句编写  

2014-04-22 10:23:29|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

 打开易语言,找到上面第一行的数据库,点击,出现结构编辑器,记录编辑器等等,点击结构编辑器,弹出一个新的数据库管理器,  在字段信息下面的名称一栏中输入“账号”在下面类型一栏选择“文本型”如果你希望输入的是数字可以选择“整数型”。点击保存,输入文件名“账号”,这样就完成名为“账号”的edb的数据库了。再到回到易语言界面,点击刚才说得上面第一行的数据库按钮弹出的最下面的加入数据库常量,选择你刚才保存的“账号.edb”数据库,这样就加入账号这个常量。 (如果你再想加密码,可以在字段“账号”后面再插入一个字段,选择“整数型”类型)。
   下面是完成别人用你的程序时输入的账号时就是把账号写入到数据库,还有是验证别人是否已经注册过的代码。
   建一个启动窗口,(你做的程序窗口放在启动窗口后面)加入一个编辑框一个按钮,把按钮命名为“注册”,双击启动窗口,在__启动窗口_创建完毕的子程序里加入代码:
   打开 (取运行目录 () + “\账号.edb”, , , , , , )       ' 这是找到存放程序的文件夹里的“账号”数据库并打开这个数据库。   (当然你的程序和数据库要放在同一个文件夹里)
  ..判断(到文本 (读 (#账号)) ≠ “”)      ' 这是判断数据库“账号”这个字段是否为空,如果不为空,就是别人已经注册过了,那就不显示启动窗口让人注册了,直接载入你做的程序窗口。    
     载入 (窗口1, , 假)                                       ' 载入你做的程序窗口。
    _启动窗口.销毁 ()

追问:

源码发我邮箱。,、、,谢谢、、、、、|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

追问:
我想要个可以放到FTP空间上的
回答:
抱歉家里电脑断网了,有源码也发不出去
追问:
哦,那过几天也可以、好的化给你加100分
回答:

易语言用户注册语句编写 - 电脑点菜 - 电脑点菜博客易语言用户注册语句编写 - 电脑点菜 - 电脑点菜博客

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击

.如果真 (编辑框1.内容 = “”)
    信息框 (“注册失败,帐号不能为空”, 16, )
    返回 ()
.如果真结束
.如果真 (编辑框2.内容 = “”)
    信息框 (“注册失败,密码不能为空”, 16, )
    返回 ()
.如果真结束
.如果真 (查找 (读 (#帐号) = 编辑框1.内容) = 真)
    信息框 (“注册失败,你注册的帐号已存在!”, 16, )
    返回 ()
.如果真结束
加空记录 ()
.如果 (写 (#帐号, 编辑框1.内容) = 真 且 写 (#密码, 编辑框2.内容) = 真)
    信息框 (“注册成功!” + #换行符 + “帐号” + 编辑框1.内容 + #换行符 + “密码” + 编辑框2.内容, 0, )
.否则
    信息框 (“注册失败”, 16, )
.如果结束
编辑框1.内容 = “”
编辑框2.内容 = “”

.子程序 __启动窗口_创建完毕

.如果真 (打开 (“C:\Documents and Settings\Administrator\桌面\数据库”, , , , , , ) = 假)  ' 这个看你自己创建的数据库地址
    信息框 (“数据库打开失败”, 0, )
.如果真结束
编辑框1.获取焦点 ()

.子程序 _按钮2_被单击

.如果真 (查找 (读 (#帐号) = 编辑框1.内容) 且 查找 (读 (#密码) = 编辑框2.内容))
    信息框 (“登录成功”, 0, )
    返回 ()
.如果真结束
信息框 (“登录失败”, 16, )

追问:
可以把数据库放到FTP空间上吗
回答:
没接触过不知道
  评论这张
 
阅读(104)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018